aboutsummaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorRunciter2024-03-31 19:52:10 +0800
committerRunciter2024-03-31 19:52:10 +0800
commita6f833087a0220b1487cb5a4550f0b0d22ba55ec (patch)
treeb806e6274813f56cf84dd48be31aa1ccb317c455 /guix.scm
downloadwhispers-command-a6f833087a0220b1487cb5a4550f0b0d22ba55ec.tar.gz
Initial.
A .gitignore A AUTHORS A COPYING A ChangeLog A HACKING A Makefile.am A NEWS A README A README.org A build-aux/test-driver.scm A configure.ac A doc/whispers.texi A guix.scm A hall.scm A pre-inst-env.in A scripts/whispers.in A whispers.scm A whispers/hconfig.scm
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm95
1 files changed, 95 insertions, 0 deletions
diff --git a/guix.scm b/guix.scm
new file mode 100644
index 0000000..743905e
--- /dev/null
+++ b/guix.scm
@@ -0,0 +1,95 @@
+(use-modules
+ (gnu packages)
+ (gnu packages autotools)
+ (gnu packages guile)
+ (gnu packages guile-xyz)
+ (gnu packages pkg-config)
+ (gnu packages texinfo)
+ (guix build-system gnu)
+ (guix download)
+ (guix gexp)
+ ((guix licenses) #:prefix license:)
+ (guix packages)
+ (srfi srfi-1))
+
+(package
+ (name "whispers")
+ (version "0.1")
+ (source
+ (local-file
+ (dirname (current-filename))
+ #:recursive?
+ #t
+ #:select?
+ (lambda (file stat)
+ (not (any (lambda (my-string)
+ (string-contains file my-string))
+ (list ".git" ".dir-locals.el" "guix.scm"))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:modules
+ ((ice-9 match)
+ (ice-9 ftw)
+ ,@%gnu-build-system-modules)
+ #:phases
+ (modify-phases
+ %standard-phases
+ (add-after
+ 'install
+ 'hall-wrap-binaries
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((compiled-dir
+ (lambda (out version)
+ (string-append
+ out
+ "/lib/guile/"
+ version
+ "/site-ccache")))
+ (uncompiled-dir
+ (lambda (out version)
+ (string-append
+ out
+ "/share/guile/site"
+ (if (string-null? version) "" "/")
+ version)))
+ (dep-path
+ (lambda (env modules path)
+ (list env
+ ":"
+ 'prefix
+ (cons modules
+ (map (lambda (input)
+ (string-append
+ (assoc-ref inputs input)
+ path))
+ ,''("guile-config"))))))
+ (out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/"))
+ (site (uncompiled-dir out "")))
+ (match (scandir site)
+ (("." ".." version)
+ (for-each
+ (lambda (file)
+ (wrap-program
+ (string-append bin file)
+ (dep-path
+ "GUILE_LOAD_PATH"
+ (uncompiled-dir out version)
+ (uncompiled-dir "" version))
+ (dep-path
+ "GUILE_LOAD_COMPILED_PATH"
+ (compiled-dir out version)
+ (compiled-dir "" version))))
+ ,''("whispers"))
+ #t))))))))
+ (native-inputs
+ (list autoconf automake pkg-config texinfo))
+ (inputs (list guile-3.0))
+ (propagated-inputs (list guile-config))
+ (synopsis
+ "Perform actions of the services of the shepherd daemons of\na whispers tree.")
+ (description
+ "The whispers command is a simple convenience wrapper\n around the herd program. Instead of specifying a file path\nto the listening socket of a running shepherd in the whispers tree, the\nuser simply provides its absolute whispers tree path as an\nargument to the --lieutenant option of this command.")
+ (home-page "")
+ (license license:gpl3+))
+